home Forums Problems or Issues Fast Slow Pro lid issue

This topic contains 2 replies, has 3 voices, and was last updated by  4Eyes 4 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #887134

    mallorcaben
    Participant

    I just received my Fast Slow Pro last week but last night I had a problem.
    After around 15 mins, a lot of steam was escaping from the pin valve.
    Then it started pinging and an error message appeared on the screen, I think it said “Lid not sealed”
    I wiggled the lid and tried gain. Same thing.
    I then removed the lid and tried again, same thing.
    I tried 5 times before giving up.
    I tested later with some water and all was fine. I used again that day, all ok.
    Last night, I went t cook again and had the same issue, I wiggled the lid, the pin valve popped up and I heard the system seal (pressurise) and my food cooked fine.
    Very frustrated.
    Has anyone got any experience of this?
    Thanks

    #887184

    Greg
    Participant

    I have gone back to using my Kuhn Rikon stovetops. My FSP sits gathering dust. It is a great design marred by a few glaring issues that could have been easily fixed with a bit more care in the prototyping stage..

    #887679

    4Eyes
    Participant

    FWIW, I have had mine for over 2 years now and never had this problem.

    Mine is the Sage branded FSP (UK version of the Breville).

    I have had it not seal because the seal wasn’t in correctly (mea culpa), but never the pin sticking.

    I guess it could be a batch control issue – can you see the pin clearly centralized in the hole when the lid is closed?

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.